poj1426Find The Multiple

文章大意就是:给你一个正整数N,让你用 1 和 0 组成一个不超过100位的数字,问这个数字是多少恰好能整除N,可能这样的数不唯一,输入其中一个就行

当时没做出来确实不应该,因为是英文题先看了眼数据,发现数据这么大,没仔细读题都以为肯定会超时。如果当时在勇敢一点吧题好好读一遍,把数据在测试一遍,应该是能做出来的。其实你能输入来的数最大也不超过19位!!!(做题也考验人的胆量,吼吼)


解题思路:其实就是一个简单的dfs,注意最大不超过19位,如果超过19位或者能整除直接return就行了,上代码吧,一看就一目了然了


Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
#include<stdio.h>
#include<string.h>
int n,f;
void dfs(long long int x,int step)
{
    if(f||step>18)return ;   //被标记或者大于18 就返回
    if(x%n==0)
    {
        f=1;
        printf("%lld\n",x);
        return ;
    }
    dfs(x*10,step+1);     //要么×10,要么×10加一,因为只有0和1
    dfs(x*10+1,step+1);
}

int main()
{
    while(~scanf("%d",&n),n)
    {
        f=0;
        dfs(1,0);    //肯定从1开始搜
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值