文章标题 POJ 3253 : Fence Repair(哈夫曼)

Fence Repair

Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input
Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8
Sample Output
34
Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
题意: 现在需要n根木棒,现有一根刚好这n根木棒总长的木棒,要将这根木棒锯n-1次得到需要的n根木棒,已知每锯一次花费的金钱刚好为这根木棒的长度,求最少的花费。
分析: 这是利用哈夫曼思想解决的,反过来思考,每次找两根最短的木棒合起来,那么想得到这两根木棒就需要花费这么多,然后再将和起来的木棒放进木堆中从新取最短的两根木棒…就这样到最后剩下一根木棒。这个和的过程反过来就是锯的过程。这个过程需要一个优先队列,每次弹出两个数。
代码

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n;
int len[20005];

int main ()
{
    while (scanf ("%d",&n)!=EOF){
        priority_queue<long long,vector<long long>,greater<long long> > q;
        long long ans=0;
        for (int i=0;i<n;i++){
            scanf ("%d",&len[i]);
            q.push(len[i]);
        }
        while (!q.empty()){
            long long a=q.top();q.pop();//拿出一根
            if (q.empty()){//如果只剩一根说明已经结束了
                break;
            }
            long long b=q.top();q.pop();//弹出第二根
            ans+=(a+b);//两根的花费
            q.push(a+b); //将新木棒放进队列中
        }
        printf ("%lld\n",ans);//输出答案
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值