文章标题 POJ 2253 : Frogger(最短路--Floyd)

Frogger

Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
题意: 一只青蛙想通过跳跃的方式从一个地方到达另外一个地方,每个地方用坐标表示,要求出从出发点到达重点过程中至少需要跳跃的距离才能保证安全到达终点而没有掉到水里。
分析:最短路问题,先用一个矩阵保存任意两点的距离,然后用Floyd算法求出最短距离。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n;
double mp[205][205];
struct node {
    int x,y;
};
node a[205];
void floyd(){
    for (int k=1;k<=n;k++){
        for (int i=1;i<=n;i++){
            for (int j=1;j<=n;j++){
                if (mp[i][j]>mp[i][k]&&mp[i][j]>mp[k][j]){//i->k,k->jd 距离都比i->j小选择i->k,k->j的路径 
                    mp[i][j]=mp[j][i]=max(mp[i][k],mp[k][j]);//选择两条边长的边 ,这样才能保证不掉水里
                }
            }
        }
    }
}
int main ()
{
    int cnt=1;
    while (scanf ("%d",&n)!=EOF){
        if (n==0) break;
        for (int i=1;i<=n;i++){
            scanf ("%d%d",&a[i].x,&a[i].y);
        }
        memset (mp,0,sizeof (mp));
        for (int i=1;i<=n-1;i++){
            for (int j=i+1;j<=n;j++){
                mp[i][j]=sqrt(fabs(pow(a[i].x-a[j].x,2))+pow(a[i].y-a[j].y,2));
                mp[j][i]=mp[i][j];
            }
        }
        for (int i=1;i<=n;i++){
            mp[i][i]=1e10;//自己到达自己初始化为无穷大
        }
        floyd();
        printf ("Scenario #%d\n",cnt++);
        printf ("Frog Distance = %.3f\n",mp[1][2]);
        printf ("\n"); 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值