文章标题 POJ 3186 : Treats for the Cows (区间DP)

3 篇文章 0 订阅

Treats for the Cows

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
题意:有一个数字序列,然后每次从两端找出一个数(有点类似双端队列),然后乘以i(i表示出现的第i个数),然后要求出这些和最大的数字,比如1, 3, 1, 5, 2,最大的值为1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43。
分析:这是一道区间DP的题,可以从里到外求出下一个区间的最大值,用dp[i][j]表示区间【i,j】的最大值,而状态转移方程为DP[i][j]=max(dp[i+1][j]+(n-len)*a[i],dp[i][j-1]+(n-len)*a[j]),len表示区间的长度,比如区间【1,5】可以从区间【2,5】和【1,4】中的最大值乘以端点来得到。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n;
int a[2005]; 
int dp[2005][2005];
int main ()
{
    while (cin>>n){
        for (int i=1;i<=n;i++){
            cin>>a[i];
        }
        int ans=0;
        memset (dp,0,sizeof(dp));
        int place=0;
        int maxn=0;
        for (int i=1;i<=n;i++){
            dp[i][i]=a[i]*n;//一个点的区间就是他自身的值 
        }
        for (int len=1;len+1<=n;len++){//区间的长度 
            for (int i=1;i+len<=n;i++){
                int j=i+len;
                //转移方程 
                dp[i][j]=max(dp[i+1][j]+(n-len)*a[i],dp[i][j-1]+(n-len)*a[j]);
            }
        }
        cout<<dp[1][n]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值