O - Treats for the Cows POJ - 3186【动态规划】

状态转移方程难与上青天啊,动态规划一直是心中的痛,但是努力的取征服它;

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.


该题的描述呢,不是太难理解,就是吧给定的数做成一个类似于双端队列(deque)的东西, 每次从队头或者对尾取出元素并做相应的乘法相加, 开始第一想法是贪心模拟一下, 但是考虑到本题出现在动态规划中,就强迫往这个方向去思考, 后来一想确实是, 因为该题的上一个状态会影响到下一个状态, 并且贪心策略中只要两边出现一个较大的数, 后边的数据和结果可能就会掉坑里,所以动态规划无论是从效率还是各方面都是很适合本题的;


既然确定了动态规划的做法, 那么下面就是状态转移方程的查找, 我们发现用天数来做dp的参数明显不可以, 所以我们选择使用二位的dp数组来记录从i->j头牛所能获得的最大利益, 也就是dp[i][j], 我们在想此时的这个dp[i][j]可能会有谁转移而来, 也就是他的下一个状态, 由于i记录的是左边的牛的序号, j记录的是右边牛的序号,i严格小于j所以,该状态可能由dp[i + 1][j] 或者 dp[i][j - 1]在乘上相应的天数而来,至于天数的计算,代码中做了相应的注释;


如理解有误,还请斧正,谢谢


#include <iostream>
#include <cstring>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;

#define maxn 2345
#define INF 0x3f3f3f3f
//dp[i][j] 表示从i号奶牛到j号奶牛的获利最大值
int dp[maxn][maxn], n, a[maxn];

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        for(int i=1;i<=n;i++){
            scanf("%d",a+i);
        }
        for(int i=n;i>=1;i--)
        {
            for(int j=i;j<=n;j++)
            {
                //状态转移方程,i --> j 可能是从前取一个或者从后取一个
                //所以状态转移为 dp[i + 1][j] 或者 dp[i][j - 1];
                //a[i] * (n + i - j) 代表的是天数,总有n天,剩下(j - i)个牛
                //所以n - (j - i)即为剩余的天数,在与a[i]相乘即可
                dp[i][j]=max(dp[i+1][j]+a[i]*(n+i-j),dp[i][j-1]+a[j]*(n+i-j));
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值