文章标题 POJ 2559 : Largest Rectangle in a Histogram (单调栈)

Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
Hint
Huge input, scanf is recommended.

题意:有n个宽度为1的矩形,然后这n个矩形紧贴在一起,然后要我们求这n个矩形所能组成的最大矩形的面积。
分析:这道题用单调栈求解,用dpl[i]和dpr[i]来维护第i个矩形距离其左边第一个比它还的低的矩形的位置与距离其右边第一个比它还低的矩形的位置,然后只要求出max( (dpr[i]-dpl[i])*h[i] )就行,此处的单调栈用上升的单调栈。
代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <stack>
using namespace std;
typedef pair<int,int> pii;


long long a[100010],dpl[100010],dpr[100010];

int n;
stack<pii>st;//第一维表示高度,第二维表示位置 

int main()
{

    while (scanf ("%d",&n)){
        if (n==0)break;
        memset (dpl,0,sizeof (dpl));
        memset (dpr,0,sizeof (dpr));
        for (int i=1;i<=n;i++){
            scanf ("%lld",&a[i]);
        }   
        while (!st.empty())st.pop();//清空栈 
        st.push(make_pair(a[1],1));
        dpl[1]=0; 
        for (int i=2;i<=n;i++){
            while (!st.empty()&&st.top().first>=a[i])st.pop();
            if (st.empty()){//如果栈已经为空了那就直接赋值为最左边即0 
                dpl[i]=0;
            }else {
                dpl[i]=st.top().second;
            }
            st.push(make_pair(a[i],i));
        }

        while (!st.empty())st.pop();

        dpr[n]=n;
        st.push(make_pair(a[n],n));
        for (int i=n-1;i>=1;i--){
            while (!st.empty()&&st.top().first>=a[i])st.pop();
            if (st.empty()){
                dpr[i]=n;
            }
            else {
                dpr[i]=st.top().second-1; 
            }
            st.push(make_pair(a[i],i));
        }
        long long ans=(dpr[1]-dpl[1])*a[1];
        for (int i=2;i<=n;i++){
            ans=max(ans,(long long)(dpr[i]-dpl[i])*a[i]);
        }
        printf ("%lld\n",ans);
    }
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值