NYoj 249

是一道简单题了,应该说是数据比较水了。。。题目如下:

描述 A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
输入
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100. Then follow n integers h1, ..., hn, where 0 <= hi <= 100000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
输出
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
样例输入
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
样例输出
8
4000
下面是代码:

#include <iostream>
#include <string.h>
using namespace std;
int main()
{
  int height[105],sum[105];
  int n,i,j,k;
  while(cin>>n&&n)
  {
    memset(height,0,sizeof(height));
	memset(sum,0,sizeof(sum));
	for(i=0;i<n;++i)
		cin>>height[i];
	int count=1;
	for( i=1;i<n;++i)
	{
	  if(height[i]<height[0])
		  break;
	  count++;
	}
	sum[0]=height[0]*count;
	for(i=1;i<n-1;++i)
	{
	  count=1;
	  for( j=i-1;j>=0;j--)
	  {
	    if(height[j]<height[i])
			break;
		count++;
	  }
	  for( k=i+1;k<n;++k)
	  {
	    if(height[k]<height[i])
			break;
		count++;
	  }
	  sum[i]=height[i]*count;
	}
	count=1;
	for( i=n-2;i>=0;--i)
	{
	   if(height[i]<height[n-1])
		   break;
	   count++;
	}
	sum[n-1]=height[n-1]*count;
	int max=0;
	for( i=0;i<n;++i)
	{
	  if(max<sum[i])
		  max=sum[i];
	}
	cout<<max<<endl;
	
  }
  return 0;
}        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值