【HDU3530】Subsequence

96 篇文章 0 订阅
15 篇文章 0 订阅

Problem Description

There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.

Input

There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

Output

For each test case, print the length of the subsequence on a single line.

Sample Input

5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5

Sample Output

5
4

思路:
我们设置两个单调队列,一个维护递增,一个维护递减
记录起点加入的编号,用一个 f r o n t front front来记录序列起点位置。
什么条件让队首出队?当递减队列队首-递增队列队首超过范围时,我们要比较两个队首入队的编号,找到比较小的那一个,将 f r o n t front front赋值,这时各队首表示的就是当前 i − f r o n t i-front ifront段的最大值和最小值,然后和答案比较

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<queue>
#include<cstring> 
using namespace std;
int n, m, k, ans=0;
int q[100006], q1[100006], a[100006];
int main()
{
   while(scanf("%d%d%d", &n, &m, &k)==3)
   {
   	memset(q, 0, sizeof(q));
   	memset(q1, 0, sizeof(q1));
   	ans=0;
   	for(int i=1; i<=n; i++)
   		scanf("%d", &a[i]);
   	int hd=1, tl=0, hd1=1, tl1=0, front=1;
   	for(int i=1; i<=n; i++)
   	{
   		while(hd<=tl&&a[i]>a[q[tl]])tl--;
   		q[++tl]=i;
   		while(hd1<=tl1&&a[i]<a[q1[tl1]])tl1--;
   		q1[++tl1]=i;
   		while(a[q[hd]]-a[q1[hd1]]>k)
   		{
   			if(q[hd]<q1[hd1])
   			{
   				front=q[hd]+1;//加一是为了跳过这个不能选的队首
   				hd++;
   			}
   			else
   			{
   				front=q1[hd1]+1;
   				hd1++;
   			}
   		}
   		if(a[q[hd]]-a[q1[hd1]]>=m)
   			ans=max(ans, i-front+1);
   	}
       printf("%d\n", ans);
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值