1004 Counting Leaves (30)(30 分)

 

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority levelstarting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

 搜索运行到树上

 

 

其实这题的题意不是这么好理解的:

给出一棵树有n个结点,m个非叶结点,然后这m个结点的信息会给出,首先给出这个结点是多少号,然后这个结点有k个子结点,然后这k个子节点的信息号

 

首先这题可以用搜索来做,这就把bfs和dfs应用到了树上

 

 

dfs:就是搜索每个父节点的儿子,每一层代表是同级别的儿子或父亲 step表示层数 当递归到最后一层的时候那么就可以把step当下标来++,

这里的dfs里的for是代表搜索父亲的儿子

#include<bits/stdc++.h>

using namespace std;
vector<int>p[150];
int n,m;
int node ,k;
int vis[150];
int maxn=-1;
void dfs(int node,int step)
{
    if(p[node].empty()){
        vis[step]++;
        maxn=max(step,maxn);
    }
    else{
        for(int i=0;i<p[node].size();i++){
            dfs(p[node][i],step+1);
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>node>>k;
        int t;
        for(int j=0;j<k;j++){
            cin>>t;
            p[node].push_back(t);
        }
    }
    dfs(1,1);
    cout<<vis[1];
    for(int i=2;i<=maxn;i++){
        cout<<" "<<vis[i];
    }
    cout<<endl;
    return 0;
}

 

bfs其实能写出一种另一种也能写出来

#include<bits/stdc++.h>

using namespace std;
struct NODE
{
    int data;
    int step;
    NODE(){}
    NODE(int data1,int step1):data(data1),step(step1){}
};
vector<int>p[150];
int n,m;
int node ,k;
int vis[150];
int maxn=-1;
void bfs(int node,int step)
{
    queue<NODE>Q;                      
    Q.push(NODE(node,step));
    while(!Q.empty()){
        NODE u=Q.front();
        Q.pop();
        if(p[u.data].empty()){
            maxn=max(u.step,maxn);
            vis[u.step]++;
        }
        for(int i=0;i<p[u.data].size();i++){
            Q.push(NODE(p[u.data][i],u.step+1));
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>node>>k;
        int t;
        for(int j=0;j<k;j++){
            cin>>t;
            p[node].push_back(t);
        }
    }
    bfs(1,1);
    cout<<vis[1];
    for(int i=2;i<=maxn;i++){
        cout<<" "<<vis[i];
    }
    cout<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值