A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (< 10^5^) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
简单是简单,但是要知道题目的意思的前提下,中间还是出了一些小错误
首先是判断n是不是prim 还有就是n的k进制是不是prim
俩个知识点 判断素数 进制转换
#include<iostream>
#include<cmath>
#include<vector>
#include<algorithm>
//#include<bits/stdc++.h>
using namespace std;
bool prim(int x)
{
if (x == 0 || x == 1) return false;
else {
int i;
for (i = 2;i <= sqrt(x);i++) {
if (x%i == 0) return false;
}
return true;
}
}
vector<int>s;
int main()
{
int n, k;
while (cin >> n, n >= 0) {
cin >> k;
s.clear();
int num1 = 0;
int temp = n;
while (temp) {
int t = temp % k;
num1 = num1 * k + t;
temp /= k;
}
if (prim(n) && prim(num1)) cout << "Yes" << endl;
else cout << "No" << endl;
}
return 0;
}