1015 Reversible Primes (20)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 10^5^) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

 

 

简单是简单,但是要知道题目的意思的前提下,中间还是出了一些小错误

 

首先是判断n是不是prim 还有就是n的k进制是不是prim

俩个知识点  判断素数  进制转换

 

#include<iostream>
#include<cmath>
#include<vector>
#include<algorithm>
//#include<bits/stdc++.h>
using namespace std;

bool prim(int x)
{
	if (x == 0 || x == 1) return false;
	else {
		int i;
		for (i = 2;i <= sqrt(x);i++) {
			if (x%i == 0) return false;
		}
		return true;
	}
}
vector<int>s;
int main()
{
	int n, k;
	while (cin >> n, n >= 0) {
		cin >> k;
		s.clear();
		int num1 = 0;
		int temp = n;
		while (temp) {
			int t = temp % k;
			num1 = num1 * k + t;
			temp /= k;
		}

		
		if (prim(n) && prim(num1)) cout << "Yes" << endl;
		else cout << "No" << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值