1079 延迟的回文数(20 分)

给定一个 k+1 位的正整数 N,写成 a​k​​⋯a​1​​a​0​​ 的形式,其中对所有 i 有 0≤a​i​​<10 且 a​k​​>0。N 被称为一个回文数,当且仅当对所有 i 有 a​i​​=a​k−i​​。零也被定义为一个回文数。

非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number )

给定任意一个正整数,本题要求你找到其变出的那个回文数。

输入格式:

输入在一行中给出一个不超过1000位的正整数。

输出格式:

对给定的整数,一行一行输出其变出回文数的过程。每行格式如下

A + B = C

其中 A 是原始的数字,B 是 A 的逆转数,C 是它们的和。A 从输入的整数开始。重复操作直到 C 在 10 步以内变成回文数,这时在一行中输出 C is a palindromic number.;或者如果 10 步都没能得到回文数,最后就在一行中输出 Not found in 10 iterations.

输入样例 1:

97152

输出样例 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

输入样例 2:

196

输出样例 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include<list>
#include<cmath>
using namespace std;
vector<int>p;
bool is(int x)
{
	vector<int>s;
	while (x) {
		s.push_back(x % 10);
		x /= 10;
	}
	int len = s.size() - 1;
	for (int i = 0;i < s.size() / 2;i++) {
		if (s[i] != s[len - i]) return false;
	}
	return true;
}
int main()
{
	int n;
	scanf("%d", &n);
	if (n == 0) printf("0 is a palindromic number.\n");
	else {
		int a = n;
		for (int i = 0;i < 10;i++) {
			p.clear();
			int b = 0;
			int t = a;
			while (t) {
				p.push_back(t % 10);
				t /= 10;
			}
			for (int j = 0;j < p.size();j++) {
				b = b * 10 + p[j];
			}
			int c = a + b;
			int len = p.size();

			printf("%d + ", a);
			for (int j = 0;j < p.size();j++) printf("%d", p[j]);
			printf(" = %d\n", c);
			if (is(c)) {
				printf("%d is a palindromic number.\n",c);
				return 0;
			}
			else {
				a = c;
			}
		}
		printf("Not found in 10 iterations.\n");

	}
	

}

 用int来判断的只得到14分 因为要是数太大是不符合,

全程用string来模拟就可以,就是大数的运用

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
bool is(string s)
{
	for (int i = 0;i < s.size() / 2;i++) {
		if (s[i] != s[s.size() - 1 - i]) return false;
	}
	return true;
}

string change(string s1)
{
	string s = s1;
	reverse(s1.begin(), s1.end());
	string t = s1;
	string ans;
	ans = s;
	int carry = 0;
	//cout << ans << "       " << s << "          " << t << "fdsaa" << endl;
	for (int i = s.size() - 1;i >= 0;i--) {
		ans[i] = (s[i] - '0' + t[i] - '0' + carry) % 10 + '0';
		carry = (s[i] - '0' + t[i] - '0' + carry) / 10;
	}
	if (carry) ans = '1' + ans;
	return ans;
}
int main()
{
	string s;
	cin >> s;
	if (s == "0") printf("0\n");
	else {
		string t = s;
		for (int i = 0;i < 10;i++) {
			if (is(t)) {
				cout << t << " is a palindromic number." << endl;
				return 0;
			}
			string t1 = t;
			string t2;
			reverse(t.begin(), t.end());
			t2 = t;
			//cout << t1 << endl;
			t = change(t1);
			cout << t1 << " + " << t2 << " = " << t << endl;
		}
	}
	cout << "Not found in 10 iterations." << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值