POJ Cube Stacking

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

 

题目大意:有N个立方体和N个格子,1~N编号,一开始i立方体在i号格子上,每个格子刚好1个立方体。现在m组操作,M a b表示将a号立方体所在的格子的全部立方体放在b号立方体所在的格子的全部立方体上面。C x表示询问x号立方体下面的立方体的个数。
 

#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
const int N = 3e4 + 10;
int p[N];
int s[N];//代表 在这个方格的总共的立方体数
int cnt[N];//代表 i  下面的立方体数
int findth(int x)
{
	if (x != p[x]) {
		int t = p[x];
		p[x] = findth(p[x]);
		cnt[x] += cnt[t];//路径压缩
	}
	return p[x];
}
void unionn(int x, int y)
{
	int xx = findth(x);
	int yy = findth(y);
	if (xx != yy) {
		p[xx] = yy;
		cnt[xx] = s[yy];
		s[yy] += s[xx];
	}
}
int main()
{
	for (int i = 1;i <= N;i++) {
		p[i] = i;
		s[i] = 1;
	}
	int T;
	scanf("%d", &T);
	while (T--) {
		char t[5];
		scanf("%s", t);
		if (t[0] == 'M'){
			int x, y;
			scanf("%d %d", &x, &y);
			unionn(x, y);
		}
		else {
			int x;
			scanf("%d", &x);
			findth(x);//路径压缩
			printf("%d\n", cnt[x]);
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值