A1019 General Palindromic Number (20分)

1019 General Palindromic Number (20分)
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
在这里插入图片描述
Sample Input 1:
27 2

Sample Output 1:
Yes
1 1 0 1 1

Sample Input 2:
121 5

Sample Output 2:
No
4 4 1

题目大意

输出n的b进制数,并判断是否是回文数。

刚读题看了两遍,好多单词不认识,,呜呜。但是看了一遍样例,秒懂。不影响做题。
求n进制模板do{}while()

  • decimal system 十进制
  • Palindromic Number 回文数
  • standard notation 标准计数法
#include <iostream>
using namespace std;
int main(){
	int n,b,num=0;
	cin >> n >> b; 
	int array[32]={0};
	do{
		array[num++]=n%b;
		n/=b;
	}while (n!=0);
	int flag=1;
	for(int i=0;i<=num/2;i++){
		if(array[i]!=array[num-1-i])
		{flag=0;
		break;
		}
	}
	if(flag==0){
		cout << "No" <<endl;
	}else cout << "Yes" << endl;	
	for (int i=num-1;i>=0;i--){
		if(i!=num-1)cout << " ";
		cout << array[i] ;
	}
	return 0;	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wvdon

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值