uva 12168 - Cat vs. Dog (最大匹配 ——最大独立集)

 

Problem C - Cat vs. Dog

Time limit: 2 seconds

The latest reality show has hit the TV: ``Cat vs. Dog''. In this show, a bunch of cats and dogs compete for the very prestigious Best Pet Ever title. In each episode, the cats and dogs get to show themselves off, after which the viewers vote on which pets should stay and which should be forced to leave the show.

Each viewer gets to cast a vote on two things: one pet which should be kept on the show, and one pet which should be thrown out. Also, based on the universal fact that everyone is either a cat lover (i.e. a dog hater) or a dog lover (i.e. a cat hater), it has been decided that each vote must name exactly one cat and exactly one dog.

Ingenious as they are, the producers have decided to use an advancement procedure which guarantees that as many viewers as possible will continue watching the show: the pets that get to stay will be chosen so as to maximize the number of viewers who get both their opinions satisfied. Write a program to calculate this maximum number of viewers.

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line with three integers c, d, v (1 ≤ c, d ≤ 100 and 0 ≤ v ≤ 500): the number of cats, dogs, and voters.
  • v lines with two pet identifiers each. The first is the pet that this voter wants to keep, the second is the pet that this voter wants to throw out. A pet identifier starts with one of the characters `C' or `D', indicating whether the pet is a cat or dog, respectively. The remaining part of the identifier is an integer giving the number of the pet (between 1 and c for cats, and between 1 and d for dogs). So for instance, ``D42'' indicates dog number 42.

Output

Per testcase:
  • One line with the maximum possible number of satisfied voters for the show.

Sample Input

2
1 1 2
C1 D1
D1 C1
1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3
The 2008 ACM Northwestern European Programming Contest
实际上,本题有两种voter,于是就有了二分图,把每个voter看成是一个点,爱好有矛盾的连一条边
这样就是最大独立集的模型了,这里在建图的时候,没有把喜欢dog的人,和喜欢cat的人分开,(实际上应该是以这两种人分开建二分图),但为了处理方便,直接把他们混在了一起,相当于每个人拆成了左右两个点,这样最大匹配的边数会是原来的两倍,所以最后求得的结果要除以二。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

int const maxn = 500 + 5;

struct BPM{
    int n,m;
    vector<int> G[maxn];
    int left[maxn];
    bool T[maxn];

    void init(int n,int m){
        this -> n = n;
        this -> m = m;
        for(int i = 0;i < n;i++) G[i].clear();
    }

    void AddEdge(int u,int v){
        G[u].push_back(v);
    }

    bool match(int u){
        for(int i = 0;i < G[u].size();i++){
            int v = G[u][i];
            if(!T[v]){
                T[v] = true;
                if(left[v] == -1 || match(left[v])){
                    left[v] = u;
                    return true;
                }
            }
        }
        return false;
    }

    int solve(){
        memset(left,-1,sizeof(left));
        int ans = 0;
        for(int u = 0;u < n;u++){
            memset(T,0,sizeof(T));
            if(match(u))    ans++;
        }
        return ans;
    }
};

BPM solver;
char like[505][10];
char disl[505][10];

int main(){
    int t,c,d,v;
    char str[20];

    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&c,&d,&v);
        solver.init(v,v);
        for(int i = 0;i < v;i++){
            scanf("%s",like[i]);
            scanf("%s",disl[i]);
        }
        for(int i = 0;i < v;i++)
            for(int j = 0;j < v;j++)
                if(!strcmp(like[i],disl[j]) || !strcmp(disl[i],like[j])){
                    solver.AddEdge(i,j);
                }
        printf("%d\n",v - solver.solve() / 2);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值