【poj 3461】 Oulipo 中文题意&题解&代码(C++)

**
Oulipo

**
Time Limit: 1000MS Memory Limit: 65536K

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

中文题意:
简单说,就是给你n组数据,每组数据中包含两个字符串s和t,找出字符串s在字符串t中出现的次数,例:ababa中字符串aba出现2次,输出2。

很简单而明显的kmp,这里给出kmp模板,有基础的同学可以自己理解,没有基础的童鞋叶可以直接背代码。博主认为本人的模板还是杠杠的!

但是无论怎样都要记住nex数组的性质,nex[i]=j代表字符串中[0…i]和[j-i…i]是相同的!!!!!!!!!!!题目主要是用nex的数组变形解题的

模板如下:

inline void get_nex()
{
        int j=-1;
        for (int i=0;i<tlen;i++)
        {
                while  (t[i]!=t[j+1] && j!=-1)      j=nex[j];
                if (t[i]==t[j+1] && i!=0) j++;
                nex[i]=j;
        }
}
inline void kmp()
{
        int j=-1;
        for (int i=0;i<slen;i++)
        {
                while  (s[i]!=t[j+1] && j!=-1) j=nex[j];
                if (s[i]==t[j+1])     j++;
                if (j==tlen-1)  ans++,j=nex[j];
        }
}

用的时候按顺序用这两个函数就求出nex数组了,ans是长串中短串出现的次数
注意nex数组的大小和那个短串相同

本题的代码如下:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char s[1000005],t[200000];
int slen,tlen;
int nex[200000];//nex数组大小和短串一致
int ans,a,b,c,d,n,m;
inline void get_nex()
{
        int j=-1;
        for (int i=0;i<tlen;i++)
        {
                while  (t[i]!=t[j+1] && j!=-1)      j=nex[j];
                if (t[i]==t[j+1] && i!=0) j++;
                nex[i]=j;
        }
}
inline void kmp()
{
        int j=-1;
        for (int i=0;i<slen;i++)
        {
                while  (s[i]!=t[j+1] && j!=-1) j=nex[j];
                if (s[i]==t[j+1])     j++;
                if (j==tlen-1)  ans++,j=nex[j];
        }
}
int main()
{
    scanf("%d",&n);
    for (int i=1;i<=n;i++)
    {
        ans=0;
        scanf("%s %s",t,s);
        slen=strlen(s);
        tlen=strlen(t);//这两个长度应该设为全局变量最开始时求出,不能用一次求一次
        get_nex();
        kmp();
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值