C - Catch That Cow POJ - 3278

Language:
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 104503 Accepted: 32686

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source



找最短路径或者最优解是多用bfs


#include<cstdio>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int vis[100005];//表示是否走过
queue<int>q;//建立整形队列
int main()
{
    int n,m;//分别表示初始位置和终点位置
    while(~scanf("%d%d",&n,&m))
    {
        memset(vis,0,sizeof(vis));//初始化数组代表还没走过
        while(!q.empty())//初始化队列
        {
            q.pop();
        }
        q.push(n);//把初始值放入队列
        vis[n]=1;//并标记走过
        while(!q.empty())
        {
            int tmp=q.front();//拿出队列首元素
            q.pop();//清空内存
            if(tmp-1>=0&&!vis[tmp-1])
            {
                q.push(tmp-1);
                vis[tmp-1]=vis[tmp]+1;
            }//后退一步
            if(tmp+1<=100000&&!vis[tmp+1])
            {
                q.push(tmp+1);
                vis[tmp+1]=vis[tmp]+1;
            }//前进一步
            if(tmp*2<=100000&&!vis[tmp*2])
            {
                q.push(tmp*2);
                vis[tmp*2]=vis[tmp]+1;
            }//传送
            if(vis[m])//如果到终点了,结束
            {
                break;
            }
        }
        printf("%d\n",vis[m]-1);//前面步数起始值为1,相当于多走了一步,这里减去
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值