HDU - 4300 Clairewd’s message(字符串匹配)

Clairewd’s message
Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone’s name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won’t overlap each other). But he doesn’t know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter’s cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;

Output
For each test case, output one line contains the shorest possible complete text.

Sample Input
2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde

Sample Output
abcdabcd
qwertabcde
题目大意:先给出与26个字母一一对应的翻译密码,再给出一个字符串,前半部分是完整的暗码,后半部分是可能有残缺的明码,让你输出完整的暗码+明码的字符串,只需要找到暗码的结束位置,然后翻译并输出在暗码之后即可
思路:这里可以不用kmp算法,只需用map记录下暗文所对应的明文,然后从串的中间往后遍历直到找到明文的开头即可。思路不难,感觉有点难想到(参考了swb大神的代码,大佬真的很严格)

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <map>

using namespace std;

const int maxn = 1e5 + 10;

char ss[maxn], s[maxn];

int main(int argc, const char * argv[])
{
    int t;
    cin >> t;
    while(t--)
    {
        cin >> s >> ss;
        map<char, char> m;
        char x = 'a';
        for(int i = 0; i < 26; i++)
        {
            m[s[i]] = x++;
        }
        int len = strlen(ss), i;
        for(i = (len+1)/2; i < len; i++)//从串中间往后遍历直至找到与翻译后开头明文匹配的位置i
        {
            int j = 0, ok = 0;
            while(ss[i+j]==m[ss[j]])
            {
                if(i+j==len-1)
                {
                    ok = 1;
                    break;
                }
                j++;
            }
            if(ok)
                break;
        }
        for(int k = 0; k < i; k++)//前半部分的暗文原样输出
            cout << ss[k];
        for(int k = 0; k < i; k++)//后半部分完整的铭文
            cout << m[ss[k]];
        cout << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值