POJ 3071 Football(0)

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all ij, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2
 
  
解题思路:概率DP,dp[i][j]表示第i轮比赛结束后j仍获胜的概率,状态转移时我们需要确定在该轮比赛时哪些选手可能与j进行比赛,然后计算概率和即可。
第1轮结束后每两位中剩余一位,第2轮结束后每4位中剩余一位,因此很容易求得。
#include <ctime>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
const int maxn = 210;
double p[maxn][maxn];
double dp[10][maxn];

int main() {

    //freopen("aa.in", "r", stdin);

    int n;
    while(scanf("%d", &n) != EOF) {
        if(n == -1) break;
        for(int i = 1; i <= (1<<n); ++i) {
            for(int j = 1; j <= (1<<n); ++j) {
                scanf("%lf", &p[i][j]);
            }
        }
        for(int i = 1; i <= (1<<n); ++i) {
            dp[0][i] = 1.0;
        }
        for(int i = 1; i <= n; ++i) {
            for(int j = 1; j <= (1<<n); ++j) {
                int k = j / (1<<(i-1));
                if(j%(1<<(i-1))) k++;
                int s, e;
                if(k%2) {
                    s = k*(1<<(i-1)) + 1;
                    e = (k+1)*(1<<(i-1));
                } else {
                    s = (k-2)*(1<<(i-1)) + 1;
                    e = (k-1)*(1<<(i-1));
                }
                dp[i][j] = 0;
                for(int l = s; l <= e; ++l) {
                    dp[i][j] += dp[i-1][j] * dp[i-1][l] * p[j][l];
                }
            }
        }
        double ans = 0.0;
        int num = -1;
        for(int i = 1; i <= (1<<n); ++i) {
            if(ans < dp[n][i]) {
                ans = dp[n][i];
                num = i;
            }
        }
        printf("%d\n", num);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值