【PTA 题解】L2-003 月饼(C + Python)

题目

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

分析

使用贪心算法,即一种一种月饼来,每一次都卖能卖钱最多的那一种。
但是注意,贪心的对象是单价,不是总价,因为题目说了,也可以只卖一部分。

具体做法是:按单价排序,从最高的开始卖,直到需求满足了为止。

代码

Python

_, demand = map(int, input().split())
mooncakes = sorted(zip(map(float, input().split()), map(float, input().split())), key=lambda x: x[1]/x[0], reverse=True)
income = 0
for storage, price in mooncakes:
    if demand >= storage:
        demand -= storage
        income += price
    else:
        income += demand * (price / storage)
        break
print(f'{income:.2f}')

C

#include <stdio.h>

int main() {
    int n, demand;
    scanf("%d %d", &n, &demand);
    double storage[n], prices[n];
    for (int i = 0; i < n; i++) {
        scanf("%lf", &storage[i]);
    }
    for (int i = 0; i < n; i++) {
        scanf("%lf", &prices[i]);
    }

    double income = 0;
    while (demand > 0 && n > 0) {
        int max_index = 0;
        for (int i = 1; i < n; i++) {
            if ((double) prices[i] / storage[i] > (double) prices[max_index] / storage[max_index]) {
                max_index = i;
            }
        }
        if (demand >= storage[max_index]) {
            income += prices[max_index];
            demand -= storage[max_index];
        } else {
            income += (double) demand / storage[max_index] * prices[max_index];
            demand = 0;
        }
        prices[max_index] = prices[n - 1];
        storage[max_index] = storage[n - 1];
        n--;
    }

    printf("%.2lf", income);

    return 0;
}
  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值