PAT甲级——Stack

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​5​​). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10​5​​.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

思路:

这里利用的分块的思想,如果使用暴力求解大概率会超时。首先将求解元素最大值开N根号的结果,这样可以将输入的元素分成 \sqrt{N}组,编号从0到\sqrt{N}。用block[\sqrt{N}]记录每个数组中的元素个数,num[N]记录每个数值存在的个数。在输入数据x的时候,根据x/\sqrt{N},选择将x加入对应的组,并且对应的block[]和num[x]要更新。出栈和入栈的时候也要更新block和num的值,记得要判断栈是否为空。

代码:

#include <iostream>
#include<cstring>
#include<stack>
using namespace std;
const int maxn = 100010;
const int sqrN = 316;//sqrt(100001),表示块内的元素

stack<int>st;//栈
int block[sqrN];//记录每一块中存在的元素
int table[maxn];//hash数组,记录元素当前存在的个数

void peekMedian(int K)
{
	int sum = 0;//sum存放当前累计存在个数
	int idx = 0;//块号
	while (sum+block[idx]<K)//找到第K大的元素所在的块号
	{
		sum += block[idx++];//未达到K,则累加上当前块的元素个数
	}
	int num = idx * sqrN;//idx号块的第一个数
	while (sum+table[num]<K)
	{
		sum += table[num++];//累加块内元素个数,直到sum达到K
	}
	printf("%d\n", num);//sum到达K,找到了第K大的数为num

}

void Push(int x)
{
	st.push(x);
	block[x / sqrN]++;
	table[x]++;
}

void Pop()
{
	int x = st.top();
	st.pop();
	block[x / sqrN]--;
	table[x]--;
	printf("%d\n", x);
}


int main()
{
	int x, query;
	memset(block, 0, sizeof(block));
	memset(table, 0, sizeof(table));
	char cmd[20];
	scanf("%d", &query);
	for (int i = 0; i < query; i++)
	{
		scanf("%s", cmd);
		if (strcmp(cmd, "Push") == 0) {
			scanf("%d", &x);
			Push(x);//入栈
		}
		else if (strcmp(cmd, "Pop") == 0) {
			if (st.empty() == true) {
				printf("Invalid\n");
			}
			else {
				Pop();
			}
		}
		else {
			if (st.empty() == true) {
				printf("Invalid\n");
			}
			else {
				int K = st.size();
				if (K % 2 == 1) K = (K + 1) / 2;
				else K = K / 2;
				peekMedian(K);
			}
				
		}
	}
	return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值