pat Stack(1057)

1057. Stack (30)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid
 
 
 
 
//1057 stack
//错误的代码
#include <stdio.h>
#include <string.h>
#include <stack>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
	int n, i, j;
	char str[15];
	stack<int> S;
	vector<int> V;
	scanf("%d", &n);
	//while(scanf("%d", &n) != EOF)
	//{
		getchar();
		while(!S.empty())
			S.pop();
		V.clear();

		for(i = 0; i < n; i++)
		{
			gets(str);
			if(strcmp(str, "Pop") == 0)
			{
				if(S.empty())
				{
					printf("Invalid\n");
				}
				else if(!S.empty())
				{
					printf("%d\n", S.top());
					V.pop_back();//不应该是V.Pop_back(), 而应该是把S.top()从vector中删除,而不是把vector中最后一个元素删除。
					S.pop();
				}
			}
			else if(strcmp(str, "PeekMedian") == 0)
			{
				if(S.empty())
					printf("Invalid\n");
				else if(!S.empty())
				{
					int m;

					if(S.size() % 2 == 0)
						m = S.size() / 2;
					else
						m = (S.size() + 1) / 2;
					sort(V.begin(), V.end());
					/*
						用这种方法虽然过了一个测试数据,但是方法本身不对。例如
						6
						Push 3
						Push 2
						Push 1
						PeekMedian
						Pop
						PeekMedian
						便得不到正确的结果。
						因为用sort对vector进行了排序,
					*/
					printf("%d\n", V[m-1]);
				}
			}
			else if(str[1] == 'u')
			{
				int tmp = 0;
				for(j = 0; j < strlen(str); j++)
					if(str[j] >= '0' && str[j] <= '9')
						tmp = tmp * 10 + str[j] - '0';

				S.push(tmp);
				V.push_back(tmp);
			}
		}
	//}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值