hdoj Largest prime factor

Largest prime factor

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

Input

Each line will contain one integer n(0 < n < 1000000).

Output

Output the LPF(n).

Sample Input

1
2
3
4
5

Sample Output

0
1
2
1
3
 
 
 
 
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define maxn 1000000+5
using namespace std;
int isprime[maxn],a[maxn];
void countprime(){
			int i,j,e=0;
			for(i=2;i*i<maxn;++i){
				if(isprime[i])continue;
				for(j=i*i;j<maxn;j+=i)
				isprime[j]=1;
			}
}
void   que(){
		int i,j=1,e=1;
		a[1]=0;
		for(i=2;i<=maxn;++i){
			if(!isprime[i]){
			for(j=i;j<maxn;j+=i){
				if(j%i==0&&j/i>i&&!isprime[j/i]);//房超时
				else a[j]=e;
			}
			e=e+1;
			}
		}
}
int main()
{
	countprime();
	que();
	int i,j,n;
	while(scanf("%d",&n)!=EOF){
		printf("%d\n",a[n]);
	}
	return 0;
}






 
 
 
 
 
 
 
 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值