南阳理工:A+B Problem II

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2  1 2  112233445566778899 998877665544332211
样例输出
Case 1:  1 + 2 = 3  Case 2:  112233445566778899 + 998877665544332211 = 1111111111111111110
 
#include<stdio.h>
#include<string.h>
#define LEN 1010
int main()
{
   int len1,len2,i,j,n,a[LEN],b[LEN],c[LEN],maxlen,k=1;
   char str1[LEN],str2[LEN];
   scanf("%d",&n);
   while(n--)
   {
        scanf("%s%s",str1,str2);
        for(i=0;i<LEN;i++)
           a[i]=b[i]=c[i]=0;
       len1=strlen(str1);
       for(j=0,i=len1-1;i>=0;i--)
          a[j++]=str1[i]-'0';//把字符转换成对应的数字,差值为48,也可以直接减去48
       len2=strlen(str2);
       for(j=0,i=len2-1;i>=0;i--)
          b[j++]=str2[i]-'0';
       maxlen=len1>len2?len1:len2;
       for(i=0;i<=maxlen+2;i++)
          {
                   c[i]=a[i]+b[i]+c[i];//注意需要加上c[i],因为c[i]种可能有上一位进上来的数
                  if(c[i]>=10)
                  {
                         c[i]-=10; 
                         c[i+1]++;
                         }
           }
         printf("Case %d:\n",k++);
         printf("%s + %s = ",str1,str2);
       for(i=maxlen+1;(c[i]==0)&&(i>0);i--);//过滤掉高位的0  
       for(;i>=0;i--)
          printf("%d",c[i]);
       printf("\n");
   }
   return 0;
}    
       
       
              
       
                 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值