南阳理工:A+B Problem II

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2  1 2  112233445566778899 998877665544332211
样例输出
Case 1:  1 + 2 = 3  Case 2:  112233445566778899 + 998877665544332211 = 1111111111111111110
 
#include<stdio.h>
#include<string.h>
#define LEN 1010
int main()
{
   int len1,len2,i,j,n,a[LEN],b[LEN],c[LEN],maxlen,k=1;
   char str1[LEN],str2[LEN];
   scanf("%d",&n);
   while(n--)
   {
        scanf("%s%s",str1,str2);
        for(i=0;i<LEN;i++)
           a[i]=b[i]=c[i]=0;
       len1=strlen(str1);
       for(j=0,i=len1-1;i>=0;i--)
          a[j++]=str1[i]-'0';//把字符转换成对应的数字,差值为48,也可以直接减去48
       len2=strlen(str2);
       for(j=0,i=len2-1;i>=0;i--)
          b[j++]=str2[i]-'0';
       maxlen=len1>len2?len1:len2;
       for(i=0;i<=maxlen+2;i++)
          {
                   c[i]=a[i]+b[i]+c[i];//注意需要加上c[i],因为c[i]种可能有上一位进上来的数
                  if(c[i]>=10)
                  {
                         c[i]-=10; 
                         c[i+1]++;
                         }
           }
         printf("Case %d:\n",k++);
         printf("%s + %s = ",str1,str2);
       for(i=maxlen+1;(c[i]==0)&&(i>0);i--);//过滤掉高位的0  
       for(;i>=0;i--)
          printf("%d",c[i]);
       printf("\n");
   }
   return 0;
}    
       
       
              
       
                 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用AngularJs编写的简单 益智游戏(附源代码)  这是一个简单的 javascript 项目。这是一个拼图游戏,也包含一个填字游戏。这个游戏玩起来很棒。有两个不同的版本可以玩这个游戏。你也可以玩填字游戏。 关于游戏 这款游戏的玩法很简单。如上所述,它包含拼图和填字游戏。您可以通过移动图像来玩滑动拼图。您还可以选择要在滑动面板中拥有的列数和网格数。 另一个是填字游戏。在这里你只需要找到浏览器左侧提到的那些单词。 要运行此游戏,您需要在系统上安装浏览器。下载并在代码编辑器中打开此项目。然后有一个 index.html 文件可供您修改。在命令提示符中运行该文件,或者您可以直接运行索引文件。使用 Google Chrome 或 FireFox 可获得更好的用户体验。此外,这是一款多人游戏,双方玩家都是人类。 这个游戏包含很多 JavaScript 验证。这个游戏很有趣,如果你能用一点 CSS 修改它,那就更好了。 总的来说,这个项目使用了很多 javascript 和 javascript 库。如果你可以添加一些具有不同颜色选项的级别,那么你一定可以利用其库来提高你的 javascript 技能。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值