Seek the Name, Seek the Fame POJ - 2752 KMP

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5


 题意就是让你求出一些子串的长度,这些子串必须是母串的前缀与后缀。
可以使用kmp算法。在next数组维护的时候,把next【i】维护成:如果i位置失去匹配,那么回溯到应该与i匹配的前一个位置(其实维护的就是最长前缀)。





例如,abcabc,next【i】分别是-1,-1,-1,0,1,2

然后str【j】不断与最后一个元素进行比较,比较完成之后在这个位置失去配,使j=next【j】,并且把这个值存放到数组用,最后输出数组。

#include<stdio.h>
#include<string.h>
using namespace std;
int next[1500000];
char str[1500000];
int s[1500000];
void getnext(int len)
{
    next[0]=-1;
    for(int i=1; i<len; i++)
    {
        int j=next[i-1];
        while(j>=0&&str[i]!=str[j+1])
            j=next[j];
        if(str[i]==str[j+1])
            next[i]=j+1;
        else
            next[i]=-1;
    }
}
int main()
{
    while(scanf("%s",str)!=EOF)
    {
        int len=strlen(str);
        getnext(len);
        int j=next[len-1];
        int cnt=0;
        while(j!=-1)
        {
            s[cnt++]=j+1;
            j=next[j];
        }
        for(int i=cnt-1; i>=0; i--)
            printf("%d ",s[i]);
        printf("%d\n",len);
    }
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值