HDU 1671 Phone List 字典树

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES
把自己恶心到了,但是明白了一个道理。

释放内存的时候并不是系统瞬间回收这一块区域,这一块的值都不会改变,仅仅是告诉编译器这一块区域可以被系统自由分配。

举个栗子,你把房子卖给了一个人,这个人可能并不会马上住进来,你也不会马上失去这间房子的钥匙,甚至房里里面的物品还没有动过,但是如果他要马上过来住,那么你必须马上走。释放内存就是这个意思

#include<bits/stdc++.h>
using namespace std;
char st[68];
struct node
{
    node *next[11];
    int ok;
};
bool ins(char *str,node *root)
{
    node *rt=root;
    bool flag=1;
    for(int i=0; str[i]; i++)
    {
        if(rt->next[str[i]-'0']==NULL)
        {
            rt->next[str[i]-'0']=new node;
            for(int j=0; j<10; j++)
                rt->next[str[i]-'0']->next[j]=NULL;
            rt->next[str[i]-'0']->ok=0;
        }
        rt=rt->next[str[i]-'0'];
        if(rt->ok>=1)
        {
            flag=0;
        }
    }
    for(int i=0; i<10; i++)
    {
        if(rt->next[i])
            flag=0;
    }
    rt->ok++;
    return flag;
}
void bt(node* &stk)
{
    if(!stk)
        return ;
    for(int i=0; i<10; i++)
    {
        bt(stk->next[i]);
    }
    delete stk;
    stk=NULL;
}
int main()
{

    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        node *root=new node;
        root->ok=0;
        for(int i=0; i<10; i++)
            root->next[i]=NULL;
        int flag=1;
        for(int i=1; i<=n; i++)
        {
            scanf("%s",st);
            if(ins(st,root)==0)
                flag=0;
        }
        bt(root);
        if(flag)
        {
            printf("YES\n");
        }
        else
            printf("NO\n");

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值