最短路:HDU3339

In Action

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8621    Accepted Submission(s): 2937


 

Problem Description


Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe.
Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it.
But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start the nuclear weapon, it must cost half of the electric network's power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station, we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use.
Now our commander wants to know the minimal oil cost in this action.

 

 

Input

The first line of the input contains a single integer T, specifying the number of testcase in the file.
For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3...n), and the number of the roads between the station(bi-direction).
Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between.
Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station's power by ID order.

 

 

Output

The minimal oil cost in this action.
If not exist print "impossible"(without quotes).

 

 

Sample Input

 

2 2 3 0 2 9 2 1 3 1 0 2 1 3 2 1 2 1 3 1 3

 

 

Sample Output

 

5

impossible

 

难以释怀看错题目这件事 题意是一辆车只能炸掉一个station,我理解成一辆车要把好几个station炸掉,想了半个多小时感觉这题好像跟最短路没有什么关系吧,然后i有看了别人题解的题意我真的当场去世,就一道很简单的floyd+dp,以后每一道最短路不管题目说没说反正都得判重边就对了,太窒息。
 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 105
#define INF 0x3f3f3f3f
int can[N][N];
int v[N];
int dp[1000005];
void floyd(int n)
{
	for(int k = 0; k <= n; k++)
	{
		for(int i = 0; i <= n; i++)
		{
			for(int j = 0; j <= n; j++)
			{
				if(can[i][j] > can[i][k] + can[k][j])
				{
					can[i][j] = can[i][k] + can[k][j];
				}
			}
		}
	}
}
int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int n, m;
		scanf("%d%d", &n, &m);
		memset(can, INF, sizeof(can));
		memset(dp, 0, sizeof(dp));
		for(int i = 0; i < m; i++)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			if(w < can[u][v])   //重边真的是最短路上WA得最多的地方
				can[u][v] = can[v][u] = w;
		}
		floyd(n);
		int sum, cnt;
		sum = cnt = 0;
		for(int i = 1; i <= n; i++)
		{
			scanf("%d", &v[i]);
			sum += v[i];
			if(can[0][i] != INF) cnt += can[0][i];
		}
		for(int i = 1; i <= n; i++)
		{
			for(int j = cnt; j >= can[0][i]; j--)  //以0到每个点的距离为背包总容量,求所能处理掉的最多的油量 
			{
				dp[j] = max(dp[j], dp[j-can[0][i]] + v[i]);
			}
		}
		bool flag = false;
		for(int i = 0; i <= cnt; i++)
		{
			if(dp[i] > sum * 1.0 / 2) //注意是more than half of
			{
				printf("%d\n", i);
				flag = true;
				break;
			}
		}
		if(!flag) printf("impossible\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值