VJ S - Key Task

原题网址VJ S - Key Task

The Czech Technical University is rather old — you already know that
it celebrates 300 years of its existence in 2007. Some of the
university buildings are old as well. And the navigation in old
buildings can sometimes be a little bit tricky, because of strange
long corridors that fork and join at absolutely unexpected places.

The result is that some first-graders have often di?culties finding
the right way to their classes. Therefore, the Student Union has
developed a computer game to help the students to practice their
orientation skills. The goal of the game is to find the way out of a
labyrinth. Your task is to write a verification software that solves
this game.

The labyrinth is a 2-dimensional grid of squares, each square is
either free or filled with a wall. Some of the free squares may
contain doors or keys. There are four di?erent types of keys and
doors: blue, yellow, red, and green. Each key can open only doors of
the same color.

You can move between adjacent free squares vertically or horizontally,
diagonal movement is not allowed. You may not go across walls and you
cannot leave the labyrinth area. If a square contains a door, you may
go there only if you have stepped on a square with an appropriate key
before. Input The input consists of several maps. Each map begins with
a line containing two integer numbers R and C (1 ≤ R, C ≤ 100)
specifying the map size. Then there are R lines each containing C
characters. Each character is one of the following:
在这里插入图片描述

Note that it is allowed to have more than one exit,

no exit at all,

more doors and/or keys of the same color, and

keys without corresponding doors and vice versa.

You may assume that the marker of your position (“*”) will appear
exactly once in every map.

There is one blank line after each map. The input is terminated by two
zeros in place of the map size. Output For each map, print one line
containing the sentence “Escape possible in S steps.”, where S is the
smallest possible number of step to reach any of the exits. If no exit
can be reached, output the string “The poor student is trapped!”
instead.

One step is defined as a movement between two adjacent cells. Grabbing
a key or unlocking a door does not count as a step.
Sample Input
1 10
*…X

1 3
#X
3 20
####################
#XY.gBr.
.Rb.G.GG.y#
####################
0 0
Sample Output
Escape possible in 9 steps.
The poor student is trapped!
Escape possible in 45 steps.

和大逃亡相似

/*
https://vjudge.net/contest/441637#problem/S
		S - Key Task
*/

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e2 + 10;
int vis[maxn][maxn][100];  // 标记拥有钥匙的情况(二进制表示)
int n, m;
char g[maxn][maxn];
struct node {
	int x, y;
	int step;
	int k;  // 到达该点的状态  钥匙情况
};
int StartX, StartY;
int dx[] = {0, 0, -1, 1};
int dy[] = {1, -1, 0, 0};

inline bool ok(int x, int y) {
	if(g[x][y] == '#') return false;
	if(x < 1 || x > n || y < 0 || y >= m) return false;
	return true;
}

inline Key(char ch) { // 转换
	if(ch == 'b' || ch == 'B') return 1;
	if(ch == 'y' || ch == 'Y') return 2;
	if(ch == 'r' || ch == 'R') return 3;
	if(ch == 'g' || ch == 'G') return 4;
}
void bfs() {
	node now;
	now.x = StartX;
	now.y = StartY;
	now.step = 0;
	now.k = 0;
	memset(vis, 0, sizeof(vis));
	queue<node > q;
	vis[now.x][now.y][now.k] = 1;
	q.push(now);
	while(!q.empty()) {
		now = q.front();
		q.pop();
		for(int i = 0; i < 4; i ++) {
			int xx = now.x + dx[i];
			int yy = now.y + dy[i];
			if(ok(xx, yy)) {
				if((g[xx][yy] == '.' || g[xx][yy] == '*')&& !vis[xx][yy][now.k]) {
					vis[xx][yy][now.k] = 1;
					node next;
					next.x = xx;
					next.y = yy;
					next.step = now.step + 1;
					next.k = now.k;
					q.push(next);
				} else if(g[xx][yy] >= 'a' && g[xx][yy] <= 'z') {
					int key = 1 << Key(g[xx][yy]);
					int temp = now.k;
					if(!(temp&key)) { // 拿上这把钥匙
						temp += key;
					}

					if(!vis[xx][yy][temp]) {
						vis[xx][yy][temp] = 1;
						node next;
						next.x = xx;
						next.y = yy;
						next.step = now.step + 1;
						next.k = temp;
						q.push(next);
					}
				} else if(g[xx][yy] >= 'A'&& g[xx][yy] <= 'Z') { // 遇到门 或 出口
					if(g[xx][yy] == 'X') {
						printf("Escape possible in %d steps.\n",now.step+1);
						return;
					}
					int key = 1<<Key(g[xx][yy]);
					if((key&now.k) && !vis[xx][yy][now.k]) {
						vis[xx][yy][now.k] = 1;

						node next;
						next.x = xx;
						next.y = yy;
						next.step = now.step + 1;
						next.k = now.k;
						q.push(next);
					}
				}
			}
		}
	}
	printf("The poor student is trapped!\n");
	return ;  
}
int main() {
	while(~scanf("%d%d", &n, &m) && n+m) {
		for(int i = 1; i <= n; i ++){
			scanf("%s", g[i]);
		}
		for(int i = 1; i <= n; i ++) {
			for(int j = 0; j < m; j ++) {
				//scanf("%c", &g[i][j]);
				if(g[i][j] == '*') {
					StartX = i, StartY = j;
				}
			}
		}
		bfs();
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值