HDU 2647 Reward

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2647

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11154    Accepted Submission(s): 3569


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
 
 
2 1 1 2 2 2 1 2 2 1
 

Sample Output
 
 
1777 -1
 

题意:发工资,n个人m个人有要求,后有m行啊,b其中a,b代表a应得的工资比b多,每人最少给888,还要求必须让所有人服气,求老板最少给多少工资。

解题思路:把各顶点链接起来是有向无环图

所用知识:拓扑排序,stl中的vector容器,队列。

源代码:

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
const int N=10050;
int nom[N],pet[N];//num记录入度,pet记录应得工资

int n,m;
using namespace std;
vector<int> eng[N];
int toposort()
{
    int sum=0;
    int k=0;
    queue<int >q;
    for(int i=1;i<=n;i++)
    {
        if(nom[i]==0)//从入度为0,进入队列
        {
            sum+=pet[i];
            q.push(i);
            k++;
        }
    }
    while(!q.empty())
    {
        int f=q.front();q.pop();
        for(int i=0;i<eng[f].size();i++)
        {
            int j=eng[f][i];
            nom[j]--;   //剪枝
            if(pet[f]+1>pet[j]) pet[j]=pet[f]+1;
            if(nom[j]==0)
            {
                sum=sum+pet[j];
                k++;
                q.push(j);
            }
        }
    }
    if(n==k) return sum;
    else return 0;
}
int main()
{

    while(scanf("%d %d",&n,&m)!=EOF)
    {
        memset(nom,0,sizeof(nom));
        for(int i=1;i<=n;i++)//初始化
        {
            pet[i]=888;
            eng[i].clear();
        }
        for(int i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            eng[b].push_back(a);
            nom[a]++;
        }
        int flot=toposort();
        if(flot) printf("%d\n",flot);
        else printf("-1\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值