HDU-1002-A + B Problem II



A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 213964    Accepted Submission(s): 41271


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L


原则上: 尽量少申请数组,没必要把字符数组转换的就不要转换 多一步骤出错的几率便会增多。其余关键点详见下面代码~字符~~字符~~~字符~~~~还是字符~~~~~






#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char a[1001] = {0}, b[1001] = {0};
int c = 0;
char add(char a,char b)
{
    char s = a + b + c;
    c = s / 10;
    return s % 10;
}
int main()
{
    char s1[1001], s2[1001];
    int t, k, i, j, len1, len2;
    cin >> t;
    for(k = 0; k < t; k++)
    {
        memset(a, 0, sizeof(a)); 
        memset(b, 0, sizeof(b));
        cin >> s1 >> s2;                      //输入
        len1 = strlen(s1);
        len2 = strlen(s2);
        for(i = 0; i < len1; i++)
            a[len1 - i - 1] = s1[i] - '0';    //替换
        for(i = 0; i < len2; i++)
            b[len2 - i - 1] = s2[i] - '0';
        cout << "Case " << k + 1 << ":\n";
        cout << s1 << " + " << s2 << " = ";
        if(len1 < len2)
            len1 = len2;                      //使len1成为较大值
        c = 0;
        for(i = 0; i < len1; i++)
            a[i] = add(a[i],b[i]) + 48;       //从低到高逐位相加,进位,存在从字符到int的转换
        if(c == 1)
            cout << c;                        //第一位输出
        for(i = len1 - 1; i >= 0; i--)        //从低到高输出
            cout << a[i];
        cout << endl;
        if(k < t - 1)
            cout << endl;
    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值