1043. Is It a Binary Search Tree (25)

题目:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

注意:
1、又是一道重建树的题目,不过已知是二叉搜索树,所以会比1020好入手一点
2、大概的思路是先试着通过递归重建,如果每一个子树不能满足题目中二叉搜索树的三个条件,则终止重建
3、后序序列的输出直接用递归,先左树,再右树,最后根节点

代码:
#include<iostream>
#include<vector>
using namespace std;
struct node
{
	int value;
	node* left;
	node* right;
}root;
vector<int>preorder; //preorder sequence
int n;//number of nodes
int yes=1;//if cannot build, yes=0
int first=1;
void rebuild(int start,int end,node *n, int mode)
{
	(*n).value=preorder[start];
	(*n).left=NULL;
	(*n).right=NULL;
	if(start==end)
		return;
	int rightstart=start+1;
	if(mode==0)//Binary Search Tree
	{
		for(;rightstart<=end;++rightstart)
			if(preorder[rightstart] > (*n).value)
				break;
		//if any element in left tree is no less than root,cannot build
		for(int i=start+1;i<rightstart;++i)
			if(preorder[i]>=(*n).value)
			{yes=0; return;}
		//if any element in right tree is less than root,cannot build
		for(int i=rightstart;i<=end;++i)
			if(preorder[i]<(*n).value)
			{yes=0; return;}
	}
	else//Mirror Image of a BST
	{
		for(;rightstart<=end;++rightstart)
			if(preorder[rightstart] < (*n).value)
				break;
		//if any element in left tree is less than root,cannot build
		for(int i=start+1;i<rightstart;++i)
			if(preorder[i]<(*n).value)
			{yes=0; return;}
		//if any element in right tree is no less than root,cannot build
		for(int i=rightstart;i<=end;++i)
			if(preorder[i]>=(*n).value)
			{yes=0; return;}
	}
	if(rightstart==start+1)
	{ //if only have right tree
		node *right= new node;
		(*n).right=right;
		rebuild(start+1,end,right,mode);
	}
	else if (rightstart==end+1)
	{ //if only have left tree
		node *left= new node;
		(*n).left=left;
		rebuild(start+1,end,left,mode);
	}
	else
	{
		node *left= new node;
		node *right= new node;
		(*n).left=left;
		(*n).right=right;
		rebuild(start+1,rightstart-1,left,mode);
		rebuild(rightstart,end,right,mode);
	}
}
void post_it(node *root)
{//print the postorder sequence
	if(root!=NULL)
	{
		post_it((*root).left);
		post_it((*root).right);
		if(first)//no space printed in front of the first element
			first=0;
		else cout<<' ' ;
		cout<<(*root).value;
	}
	return;
}
int main()
{
	cin>>n;
	for(int i=0;i<n;++i)
	{
		int t;
		cin>>t;
		preorder.push_back(t);
	}
	rebuild(0,n-1,&root,0); //check if it is Binary Search Tree
	if(yes==1)
	{
		cout<< "YES"<<endl;
		post_it(&root);
	}
	else
	{
		yes=1;
		rebuild(0,n-1,&root,1); //check if it is a Mirror Image of Binary Search Tree
		if(yes==1)
		{
			cout<< "YES"<<endl;
			post_it(&root);
		}
		else cout<<"NO" <<endl;
	}        
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【Solution】 To convert a binary search tree into a sorted circular doubly linked list, we can use the following steps: 1. Inorder traversal of the binary search tree to get the elements in sorted order. 2. Create a doubly linked list and add the elements from the inorder traversal to it. 3. Make the list circular by connecting the head and tail nodes. 4. Return the head node of the circular doubly linked list. Here's the Python code for the solution: ``` class Node: def __init__(self, val): self.val = val self.prev = None self.next = None def tree_to_doubly_list(root): if not root: return None stack = [] cur = root head = None prev = None while cur or stack: while cur: stack.append(cur) cur = cur.left cur = stack.pop() if not head: head = cur if prev: prev.right = cur cur.left = prev prev = cur cur = cur.right head.left = prev prev.right = head return head ``` To verify the accuracy of the code, we can use the following test cases: ``` # Test case 1 # Input: [4,2,5,1,3] # Output: # Binary search tree: # 4 # / \ # 2 5 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 <-> 4 <-> 5 # Doubly linked list in reverse order: 5 <-> 4 <-> 3 <-> 2 <-> 1 root = Node(4) root.left = Node(2) root.right = Node(5) root.left.left = Node(1) root.left.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) # Test case 2 # Input: [2,1,3] # Output: # Binary search tree: # 2 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 # Doubly linked list in reverse order: 3 <-> 2 <-> 1 root = Node(2) root.left = Node(1) root.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) ``` The output of the test cases should match the expected output as commented in the code.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值