If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:3 12300 12358.9Sample Output 1:
YES 0.123*10^5Sample Input 2:
3 120 128Sample Output 2:
NO 0.120*10^3 0.128*10^3
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
int k[2],n;
char a[2][105],b[2][105];
scanf("%d%s%s",&n,a[0],a[1]);
int len[2]={strlen(a[0]),strlen(a[1])};
for(int i=0;i<2;++i)
{
int firstdigit=-1,dot=len[i],count=0;
for(int j=0;j<len[i];++j)
{//check every char in the input string
if(firstdigit<0 && a[i][j]>'0' && a[i][j]<='9')
{//if it is the first significant digit
firstdigit=j;
b[i][count++]=a[i][j];
}
else if(firstdigit>=0 && count<n && a[i][j]!='.')
b[i][count++]=a[i][j];
if(a[i][j]=='.')//find the position of dot
dot=j;
}
//if the digit lenght of input isn't enough, '0' need to be fullfilled to back
if(count<n)
while(count<n)
b[i][count++]='0';
b[i][count]='\0';
if(firstdigit>=0)
k[i]=dot>firstdigit?dot-firstdigit:dot-firstdigit+1;
else k[i]=0;//that means a[i]="0"
}
if(strcmp(b[0],b[1])==0 && k[0]==k[1])
printf("YES 0.%s*10^%d\n",b[0],k[0]);
else
printf("NO 0.%s*10^%d 0.%s*10^%d\n",b[0],k[0],b[1],k[1]);
return 0;
}