题目:
Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.
Input Specification:
The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).
Sample Input:3 1 2 3 2 3 4 9223372036854775807 -9223372036854775808 0Sample Output:
Case #1: false Case #2: true Case #3: false
注意:
1、这里考察的是对于溢出的处理,把两种溢出的情况找出来分别处理就可以了。
代码:
#include<iostream>
using namespace std;
int main()
{
long long a,b,c;
int n;
scanf("%d",&n);
for(int i=0;i<n;++i)
{
scanf("%lld%lld%lld",&a,&b,&c);
long long s=a+b;
bool t;
if(a>0&&b>0&&s<=0)
t=true;
else if(a<0&&b<0&&s>=0)
t=false;
else
t=s>c;
printf("%s%d: %s\n","Case #",i+1,t?"true":"false");
}
return 0;
}