1072. Gas Station (30)

题目:

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution
注意:
1、30分的题目一次AC还是第一次。。。
2、又是图论的题目,其实只要根据题目要求结合最短路径算法就应该不难的,这里比较蛋疼的是有两种node,gas station和resident,把gas station当做普通的node就好了,最短路径计算的时候要把所有node都放在一张网里面计算,然后只计算那几个gas station到所有其他node的距离,剔除那些最大距离超过service range的station,然后排序,或者不排序,直接算题目要求的station也可以。我是用排序来做的。
3、注意No Solution的情况。

代码:
//1072
#include<iostream>
#include<vector>
#include<cstring>
#include<cmath>
#include<algorithm>
#define inf 65535
using namespace std;
vector<int>dist;//distance to each house
vector<vector<int>>G;//the 2D graph matrix

struct Gas
{
	int index;
	float mindist;
	float avedist;
	bool operator > (const Gas &g)const
	{
		if(mindist!=g.mindist)
			return mindist>g.mindist;
		else if(avedist!=g.avedist)
			return avedist<g.avedist;
		else
			return index<g.index;
	}
};

void dijkstra(int station)
{//calculate the distance between a station and each house
	dist=G[station];
	vector<int>visited;
	visited.assign(dist.size(),0);
	int k=station;//the current node to calculate
	visited[k]=1;
	while(1)
	{
		int index=0,min=inf;
		for(int i=1;i<dist.size();++i)
		{//find the nearest unvisited node
			if(!visited[i]&&dist[i]<min)
			{
				index=i;
				min=dist[i];
			}
		}
		if(index==0)//if nodes are all visited
			break;
		visited[index]=1;//set this node to be visited
		for(int i=1;i<dist.size();++i)
		{//check if other nodes can shorter their distance through this node
			if(!visited[i] && dist[index]+G[index][i]<dist[i])
				dist[i]=dist[index]+G[index][i];
		}
	}
}

int main()
{
	//n (<= 10^3), the total number of houses
	//m (<= 10), the total number of the candidate locations for the gas stations
	//k (<= 10^4), the number of roads connecting the houses and the gas stations
	//ds, the maximum service range of the gas station
	int n,m,k,ds;
	scanf("%d%d%d%d",&n,&m,&k,&ds);
	G.resize(n+m+1);
	for(int i=0;i<=n+m;++i)
	{
		G[i].assign(n+m+1,inf);
		G[i][i]=0;
	}
	for(int i=0;i<k;++i)
	{//build the road
		int a[3]={0};
		for(int j=0;j<2;++j)
		{//find the index of two nodes in each road
			char in[5];
			scanf("%s",in);
			int isG=0;
			for(int ii=0;ii<strlen(in);++ii)
			{
				if(in[ii]=='G')
					isG=1;
				else
					a[j]=a[j]*10+in[ii]-'0';
			}
			if(isG)//if it is a Gasstation, the index of Gm is n+m
				a[j] += n;
		}
		scanf("%d",&a[2]);//the distance betweent a[0] and a[1]
		G[a[0]][a[1]]=a[2];
		G[a[1]][a[0]]=a[2];
	}
	vector<Gas>possible;//the possible station that can serve all the residents
	for(int i=n+1;i<=n+m;++i)
	{//calculate the minimum,maximun,and average distance
		dijkstra(i);
		int min=inf,max=0,sum=0;
		for(int j=1;j<=n;++j)
		{
			sum+=dist[j];
			if(dist[j]>max) max=dist[j];
			if(dist[j]<min) min=dist[j];
		}
		if(max<=ds)
		{//if maximum distance is still in the service range
			Gas g;
			g.index=i;
			g.mindist=float(min);
			g.avedist=float(sum)/float(n);
			possible.push_back(g);
		}
	}
	if(possible.size()==0)
	{
		printf("No Solution\n");
		return 0;
	}
	sort(possible.begin(),possible.end(),greater<Gas>());
	printf("G%d\n%.1f %.1f\n",possible[0].index-n,possible[0].mindist,possible[0].avedist);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
用c++解决pipeline system consists of N transfer station, some of which are connected by pipelines. For each of M pipelines the numbers of stations A[i] and B[i], which are connected by this pipeline, and its profitability C[i] are known. A profitability of a pipeline is an amount of dollars, which will be daily yielded in taxes by transferring the gas through this pipeline. Each two stations are connected by not more than one pipeline. The system was built by Soviet engineers, who knew exactly, that the gas was transferred from Ukrainian gas fields to Siberia and not the reverse. That is why the pipelines are unidirectional, i.e. each pipeline allows gas transfer from the station number A[i] to the station number B[i] only. More over, if it is possible to transfer the gas from the station X to the station Y (perhaps, through some intermediate stations), then the reverse transfer from Y to X is impossible. It is known that the gas arrives to the starting station number S and should be dispatched to the buyers on the final station number F. The President ordered the Government to find a route (i.e. a linear sequence of stations which are connected by pipelines) to transfer the gas from the starting to the final station. A profitability of this route should be maximal. A profitability of a route is a total profitability of its pipelines. Unfortunately, the President did not consider that some pipelines ceased to exist long ago, and, as a result, the gas transfer between the starting and the final stations may appear to be impossible... Input The first line contains the integer numbers N (2 ≤ N ≤ 500) and M (0 ≤ M ≤ 124750). Each of the next M lines contains the integer numbers A[i], B[i] (1 ≤ A[i], B[i] ≤ N) and C[i] (1 ≤ C[i] ≤ 10000) for the corresponding pipeline. The last line contains the integer numbers S and F (1 ≤ S, F ≤ N; S ≠ F). Output If the desired route exists, you should output its profitability. Otherwise you should output "No solution".
05-28
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值