1090. Highest Price in Supply Chain (25)

题目:

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2
注意:
1、我这里使用的是类似于dfs的方法,搜索最近的那个已经计算出层数的结点然后递归得到这条路径上的所有结点的层数。2、当然也可以使用bfs来层序遍历,不过就需要在读取pre的时候把树建立好。
3、注意输出的第二个参数是售价最高的零售商的个数而不是层数。

代码:
//1090
#include<iostream>
#include<vector>
using namespace std;

vector<int>pre;//the provider of each chain
vector<int>level;//the level number of each chain

void calculevel(int k)
{//calculate level for each chain
	if(pre[k]==-1)
	{//stop the recursion when meeting the root supplier
		level[k]=0;
		return;
	}
	if(level[pre[k]]==-1)//uncalculated
		calculevel(pre[k]);
	level[k]=level[pre[k]]+1;
}

int main()
{
	int n;
	double price,rate;
	scanf("%d%lf%lf",&n,&price,&rate);
	pre.resize(n);
	level.assign(n,-1);
	for(int i=0;i<n;++i)
		scanf("%d",&pre[i]);
	for(int i=0;i<n;++i)
	{
		if(level[i]==-1)
			calculevel(i);
	}
	int maxlevel=0,count=0;
	for(int i=0;i<n;++i)
	{//find the max level and count the number
		if(level[i]>maxlevel)
		{
			maxlevel=level[i];
			count=1;
		}
		else if(level[i]==maxlevel)
			++count;
	}
	for(int i=0;i<maxlevel;++i)
		price*=1+rate/100;
	printf("%.2f %d\n",price,count);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值