1066 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 

 

#include "iostream"

using namespace std;

struct node{

    int data;

    int height;

    node* lchild;

    node* rchild;

};

const int maxn=100;

int n;

 

int getHeight(node* root){

    if (root==NULL) {

        return 0;

    }

    return root->height;

}

 

void updateHeight(node* &root){

    root->height=max(getHeight(root->lchild), getHeight(root->rchild))+1;

}

 

int getBalance(node* root){

    return (getHeight(root->lchild)-getHeight(root->rchild));

}

 

void Rrotate(node* &root){

    node* temp=root->lchild;

    root->lchild=temp->rchild;

    temp->rchild=root;

    updateHeight(root);

    updateHeight(temp);

    root=temp;

}

 

void Lrotate(node* &root){

    node* temp=root->rchild;

    root->rchild=temp->lchild;

    temp->lchild=root;

    updateHeight(root);

    updateHeight(temp);

    root=temp;

}

 

node* newnode(int v){

    node* n=new node;

    n->data=v;

    n->height=1;

    n->lchild=NULL;

    n->rchild=NULL;

    return n;

}

 

void insertNode(node* &root,int v){

    if (root==NULL) {

        root=newnode(v);

        return;

    }

    if (v<root->data) {

        insertNode(root->lchild, v);

        updateHeight(root);

        if (getBalance(root)==2) {

                if (getBalance(root->lchild)==-1) {

                    Lrotate(root->lchild);

                    Rrotate(root);

                }

                else{

                    Rrotate(root);

                }

            }

        }

    else{

        insertNode(root->rchild, v);

        updateHeight(root);

        if (getBalance(root)==-2) {

                if (getBalance(root->rchild)==1) {

                    Rrotate(root->rchild);

                    Lrotate(root);

                }

                else{

                    Lrotate(root);

                }

        }

    }

}

 

int main(){

    scanf("%d",&n);

    node* root=NULL;

    for (int i=0; i<n; i++) {

        int number;

        scanf("%d",&number);

        insertNode(root, number);

    }

    printf("%d",root->data);

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值