PAT-甲级-1066 Root of AVL Tree (25 分)

60 篇文章 0 订阅

1066 Root of AVL Tree (25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88
#include <iostream>
#include <vector>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
struct node{
    int d;
    node *l,*r;
};
node* left(node *u){
    node *t = u->r;
    u->r = t->l;
    t->l = u;
    return t;
}
node* right(node *u){
    node *t = u->l;
    u->l = t->r;
    t->r = u;
    return t;
}
node* lr(node *u){
    u->l = left(u->l);
    return right(u);
}
node* rl(node *u){
    u->r = right(u->r);
    return left(u);
}
int getH(node *u){
    if(u==NULL)    return 0;
    return max(getH(u->l),getH(u->r)) + 1;
}
node* insert(node *u,int d){
    if(u==NULL){
        u = new node();
        u->d = d;
        u->l = u->r = NULL;
    }else if(d < u->d){
        u->l = insert(u->l,d);
        if(getH(u->l) - getH(u->r) == 2)
            u = d < u->l->d ? right(u) : lr(u);
    }else{
        u ->r = insert(u->r,d);
        if(getH(u->l) - getH(u->r) == -2)
            u = d > u->r->d ? left(u) : rl(u);
    }
    return u;
}
int main(){
    std::ios::sync_with_stdio(false);
    int n,a;
    cin>>n;
    node *root = NULL;
    rep(i,0,n){
        cin>>a;
        root = insert(root,a);
    }
    printf("%d",root->d);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值