HDU 1005 Number Sequence 【找循环周期(瞎搞)】

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5

题意:给你A、B和n的值让你计算f(n)的值(f(n)的定义已给出)。

思路:递归?或者直接打表?但你看看n的范围,肯定行不通。题目中又有%这个条件,所以很显然找规律啊。因为每次的输入,A和B的值不变,而且取余后每个a[?]都只有7种情况,所以一共有7*7种情况,然后再打表就好了。

AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int ans[55];
int main()
{
    ans[1] = ans[2] = 1;
    int a, b, n;
    while(~scanf("%d%d%d",&a, &b, &n))
    {
        if(a == 0 && b == 0 && n == 0) break;
        for(int i = 3; i < 50; ++i)
            ans[i] = (ans[i - 1] * a + ans[i -2] * b) % 7;
    cout << ans[n % 49] << endl;
    }
    return 0;
}
当然还可以稍微优化一下,就是n≤49时可以打表到n
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值