1990 ICPC WF C Repeating Decimals 【数组和字符串】【模拟】

题目链接:
UVa 202 Repeating Decimals

Description:
The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating cycles.
Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.
fraction decimal expansion repeating cycle cycle length 1/6 0.1(6) 6 1 5/7 0.(714285) 714285 6 1/250 0.004(0) 0 1 300/31 9.(677419354838709) 677419354838709 15 655/990 0.6(61) 61 2
Write a program that reads numerators and denominators of fractions and determines their repeating cycles.
For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input
Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end of input.

Output
For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire repeating cycle. In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins — it will begin within the first 50 places — and place ‘…)’ after the 50th digit.

Sample Input
76 25
5 43
1 397

Sample Output
76/25 = 3.04(0)
1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992…)
99 = number of digits in repeating cycle

题目大意:
输入整数a和b,输出a/b的循环小数表示以及循环节长度。

解题思路:
n除以m的余数只能是0~m-1,所以当我们计算m+1次时至少存在一个余数相同,而这个余数前一个相同的余数到这个余数之间内容就是循环的部分了。
具体的解决办法我用cx数组记录出现过的被除数,fs数组表示每次被除数/m后得到的小数部分,每次得到新的被除数后就去判断之前是否出现过。
其中模拟除法的过程中被除数就是t%m*10

Mycode:

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MAX = 3005;
const int MOD = 1e9+7;
const int INF = 0x3f3f3f3f;

int cx[MAX];
int fs[MAX];
int main()
{
    int n, m, t, i;
    int cou, cas = 0;
    while(cin >> n >> m)
    {
        cou = 0;
        memset(cx, 0, sizeof(cx));
        memset(fs, 0, sizeof(fs));
        printf("%d/%d = %d.",n, m, n/m);

        t = n;
        while(1)
        {
            t = t % m * 10;
            fs[cou] = t / m;
            for(i = 0; i < cou; ++i)
                if(cx[i] == t) break;
            if(i != cou) break;
            cx[cou++] = t;
        }

        for(int q = 0; q < i; ++q)
            cout << fs[q];
        cout << "(";

        if(cou > 50)
        {
            for(int q = i; q < i+50; ++q)
                cout << fs[q];
            cout << "...";
        }
        else
        {
            for(int q = i; q < cou; ++q)
                cout << fs[q];
        }
        cout << ")\n";
        printf("   %d = number of digits in repeating cycle\n\n", cou-i);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值