Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4863 Accepted: 1983
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4
小结:
还好,我好像越来越感觉分不清楚什么是DFS和BFS了.....还有,为什么有些大神这道题目可以16MS秒杀....
暴力求解吧....每个位置只可能有两种情况,翻和不翻。
以下是AC代码:
#include<stdio.h>
#include<string.h>
struct node
{
char map[5][5];
int ans;
};
int flag,fans;
int x[6]={0,1,0,-1,0};
int y[6]={1,0,-1,0,0};
int allsame(struct node a)
{
for(int i=1;i<=4;i++)
for(int j=1;j<=4;j++)
if(a.map[i][j]!=a.map[1][1])
return 0;
return 1;
}
int ok(int a,int b)
{
if(a<1||b<1||a>4||b>4)
return 0;
return 1;
}
void change(struct node *a,int row,int col)
{
for(int i=0;i<5;i++)
{
int aa=row+x[i];
int bb=col+y[i];
if(ok(aa,bb))
{
(*a).map[aa][bb]=(*a).map[aa][bb]=='w'?'b':'w';
}
}
}
void dfs(struct node a,int row,int col)
{
if(allsame(a))
{
fans=a.ans<fans?a.ans:fans;
flag=1;
return;
}
if(row>4)
return;
dfs(a,row+col/4,col==4?1:col+1);
struct node temp=a;
change(&temp,row,col);
temp.ans++;
dfs(temp,row+col/4,col==4?1:col+1);
}
int main()
{
struct node init;
fans=20;
flag=0;
for(int i=1;i<=4;i++)
{
scanf("%s",init.map[i]+1);
}
init.ans=0;
dfs(init,1,1);
if(flag)
printf("%d\n",fans);
else
printf("Impossible\n");
return 0;
}