PAT—甲级-1086

1086. Tree Traversals Again (25)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
【解析】
这道题的话其实用到stack比较好用我们可以了解到这个入栈操作其实就是他的先序遍历,而它的出栈则是中序遍历,要求我们输出后序遍历。就是递归求后序的问题了。
#include <cstdio>
#include <vector>
#include <stack>
#include <cstring>
using namespace std;
vector<int> a, b, c;
void tree(int root, int start, int end) {
    if(start > end) return ;
    int i = start;
    while(i < end && b[i] != a[root]) i++;//a是中先序遍历当中的,这事求在中序遍历中i的位置
    tree(root + 1, start, i - 1);
    tree(root + 1 + i - start, i + 1, end);
    c.push_back(a[root]);
}
int main() {
    int n;
    scanf("%d", &n);
    char s[10];
    stack<int> zhan;
    while(~scanf("%s",s))
        {
        if(strlen(s) == 4) {
            int num;
            scanf("%d",&num);
            a.push_back(num);//先序遍历
            zhan.push(num);
        } else {
            b.push_back(zhan.top());
            zhan.pop();
        }
    }
    tree(0, 0, n - 1);
    printf("%d", c[0]);
    for(int i = 1; i < n; i++)
        printf(" %d", c[i]);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值