PAT-甲级-1007

1007. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
【解析】
这道题的意思就是让你求最大的上升序列加起来有多大,并且叫你输出从哪个元素加到哪个元素是最大的,这里我们还要注意的一点是如果每个元素都小于0那么我们就认为最大是0,然后输出首尾元素。
#include<iostream>
#include<string>
#include<vector>
#include<cstdio>
using namespace std;
int main()
{
    int n,m,i,left,right,p=0,sum=-1,flag=0,q=0;
    scanf("%d",&n);
    vector<int>a(n);
     for(i=0;i<n;i++)
    {
         scanf("%d",&a[i]);
        if(a[i]>=0)
            flag=1;//flag标记看是否所有的元素都小于0
          p=p+a[i];//不断的加上元素
        if(p>sum)//比之前的总和大的话就改变首尾的下标
        {
            sum=p;
            left=q;
            right=i;
        }
        if(p<0)//小于0果断的置0
        {
            p=0;
            q=i+1;//开始的下标为这个元素的下一个
        }
    }
    if(flag==0)
        printf("0 %d %d",a[0],a[n-1]);//所有元素都小于0的情况
    else
        printf("%d %d %d",sum,a[left],a[right]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值