01-复杂度2 Maximum Subsequence Sum

01-复杂度2 Maximum Subsequence Sum   (25分)

Given a sequence of KK integers { N_1N1N_2N2, ..., N_KNK }. A continuous subsequence is defined to be { N_iNiN_{i+1}Ni+1, ..., N_jNj } where 1 \le i \le j \le K1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KK (\le 1000010000). The second line contains KK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices ii and jj (as shown by the sample case). If all the KK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


题目思路:Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.不仅要给出输入的数据的最大子列和,还要给出子列和的开始和结尾。

1.当有两个最大子列和相等时,输出靠前的节点

2.当子列和全为负数时,输出0,以及序列的头节点和尾节点

通过老师给的参考算法,稍稍改动就好

#include<stdio.h>
#include<stdlib.h>
#define MAXN 100001 	

int MaxSubseqSum2( int A[], int N);

int index_0 = 0;//用来计算最大子列和开始下标
int index_1 = 0;//用来计算最大子列和结束下标


int main()
{
	int a[MAXN],index_flag = -1;//用来记录0的下标 

	int K,maxnum;
	
	scanf("%d",&K);
	for(int i=0; i<K; i++)
	{
		scanf("%d",&a[i]);
		if(a[i]==0)
		{
			index_flag = i;	
		} 
	}
	
	maxnum = MaxSubseqSum2(a,K);
	if(maxnum==0)//可能全是负数,也可能相加正好为0
	{
		if(index_flag>=0) //如果0和负数存在,第一个输出0,最后一个输出0
		{
			a[index_0] = 0;
			a[index_1] = 0;//
		}
		else
		{
			index_0 = 0;
			index_1 = K-1;
		}
	}

	printf("%d %d %d",maxnum,a[index_0],a[index_1]);

	 
	return 0;
}

int MaxSubseqSum2( int A[], int N)
{
	int ThisSum,MaxSum = 0;
	int i,j;
	for( i = 0; i < N; i++ )//i是子列左端
	{
		ThisSum = 0;//ThisSum是A[i]到A[j]的子列和
		for( j = i; j < N; j++)//j是子列右端
		{
			ThisSum+=A[j];
			//对于相同的i,不同的j,只要j-1次循环的基础上累加1项即可
			if( ThisSum > MaxSum)
				{
					index_0 = i;
					index_1 = j; 
					MaxSum = ThisSum;
				}
		}//j循环结束
	}//i循环结束
	return MaxSum;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值