最大子序列问题

最近在回顾数据结构,听了mooc的浙江大学的课程http://www.icourse163.org/learn/zju-93001#/learn/announce,

第一课就是这个问题,觉得挺好的,就记录下来了,问题如下:

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

自己照着修改的源码如下:

#include <stdio.h>
#include <stdlib.h>
  int main()
{int length;
int *a=0;
 int thissum=0;
int sum=0;
 int i=0;

 //这是自己添加啊,为了找到子序列的起止位置,加了j,end,span
int span=1;
int end;
int j=0;
scanf("%d",&length);
a=(int *)malloc(sizeof(int)*length);
for(i=0;i<length;i++)
{
scanf("%d",&a[i]);
}
/*  int a[]={1,3,-4,6,7,-5,8,-3,2};
*/
for(i=0;i<length;i++)
  {
/*   printf("a[%d]=%d\n",i,a[i]);
  */
  thissum+=a[i];


 if(thissum>0) 
    {
     j++;
    }

 if(thissum>sum)
    {
    sum=thissum;
     end=i;
    span=j;

    }
   else if(thissum<0)
    { thissum=0;
      j=0;
    }
   }


printf("%d %d %d",sum,a[end-span+1],a[end]);
  return 0;


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值