hdu 3172 Virtual Friends 并查集

Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

Input

Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest. 
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

Sample Input

       
       
1 3 Fred Barney Barney Betty Betty Wilma
 

Sample Output

       
       
2 3 4
  题意:给你两个人,他们刚成为朋友,问在这两个人的社交圈里有多少个朋友?提示:朋友的朋友也是你的朋友。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<map>
using namespace std;
int set[210000],num[210000];
int find(int x)
{
    if(set[x]!=x)
        set[x]=find(set[x]);
    return set[x];
}
void get(int x,int y)
{
    int xx=find(x);
    int yy=find(y);
    if(xx!=yy)
    {
        set[yy]=xx;
        num[xx]+=num[yy];
        printf("%d\n",num[xx]);
    }
    else
        printf("%d\n",num[yy]);
}
int main()
{
    int T,n,k;
    char s1[60],s2[60];
    while(scanf("%d",&T)!=EOF)
    {
        while(T--)
        {

            scanf("%d",&n);
            for(int i=1; i<=210000; i++)
            {
                set[i]=i;
                num[i]=1;
            }
            k=1;
            map<string,int> m;
            for(int i=0; i<n; i++)
            {
               scanf("%s %s",s1,s2);
                if(!m[s1])
                    m[s1]=k++;
                if(!m[s2])
                    m[s2]=k++;
                get(m[s1],m[s2]);
            }
        }
    }
    return 0;
}

难点就在于怎么把字符串转换为数字

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值