Phone List(字典树)

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

 题意

  给定n个长度不超过10的数字串,问其中是否存在两个数字串S,T,使得S是T的前缀。有多组数据,数据组数不超过40.n<=10^4

思路

 考虑将所有的字符串构成一棵Trie,在构建过程中可以顺便判断答案。若当前串插入后没有新建任何结点,则当前串肯定是之前插入的某个串的前缀;若插入过程中,有某个经过的结点带有串尾标记,则之前插入的某个串是当前串的前缀。依据上述两种情况判断

代码

#include<stdio.h>
#include<string.h>
#define N 100005
#define Z 10
int ch[N][Z],tot,bo[N];
int Insert(char *s) //插入一个字符串同时判断答案
{
    int len=strlen(s);
    int u=1,flag=0,i;
    for(i=0;i<len;i++)
    {
        int c=s[i]-'0';
        if(!ch[u][c])
            ch[u][c]=++tot;
        else if(i==len-1)
            flag=1;  //没有插入任何新结点
        u=ch[u][c];
        if(bo[u])
           flag=1;  //经过某个有标记的结点
    }
    bo[u]=1;
    return flag;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,ans=0;
        char s[20];
        scanf("%d",&n); tot=1;
        memset(ch,0,sizeof(ch));
        memset(bo,0,sizeof(bo));
        while(n--)
        {
            scanf("%s",s);
            if(Insert(s)) ans=1;
        }
        if(ans)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值