PAT 1059 Prime Factors(质因数分解)

 Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

 Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

 Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

代码

#include<cstdio>
#include<cmath>
#include<vector>
using namespace std;
typedef long long LL;
vector<int> factor;
vector<int> index;
void Divide(LL N)
{
    int Num,Temp=N;
    //质因数分解算法
    for(int i=2;i*i<=N;i++)
    {
        if(N%i==0)
        {
            factor.push_back(i);
            Num=0;
            while(N%i==0)
            {
                N/=i;
                Num+=1;
            }
            index.push_back(Num);
        }
    }
    if(N>1)
    {
        factor.push_back(N);
        index.push_back(1);
    }
    int Len=factor.size();
    printf("%d=",Temp);
    for(int i=0;i<Len;i++)
    {
        if(i==0)
        {
            if(index[i]!=1)
                printf("%d^%d",factor[i],index[i]);
            else
                printf("%d",factor[i]);
        }
        else
        {
            if(index[i]!=1)
                printf("*%d^%d",factor[i],index[i]);
            else
                printf("*%d",factor[i]);
        }
    }
    return ;
}
int main()
{
    LL N;
    scanf("%lld",&N);
    if(N==1)
        printf("1=1");
    else
        Divide(N);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值