We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array. We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1, a2, …, an, is it almost sorted?
Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1, a2, …, an. • 1 ≤ T ≤ 2000 • 2 ≤ n ≤ 105 • 1 ≤ ai ≤ 105 • There are at most 20 test cases with n > 1000.
Output
For each test case, please output ‘YES’ if it is almost sorted. Otherwise, output ‘NO’ (both without quotes).
Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
Sample Output
YES
YES
NO
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <cstdio>
#include <string>
#include <stack>
#include <deque>
using namespace std;
const int MAX=1e5+7;
typedef long long ll;
ll a[MAX],ans[MAX];
int main()
{
ll T,i,j,len,n;
cin>>T;
while(T--)
{
cin>>n;
for(i=1; i<=n; i++)
cin>>a[i];
ans[1]=a[1];
len=1;
for(i=2; i<=n; i++)
{
if(a[i]>=ans[len])
ans[++len]=a[i];
else
{
ll pos=upper_bound(ans+1,ans+len+1,a[i])-ans;
ans[pos]=a[i];
}
}
if(len>=n-1)
cout<<"YES"<<endl;
else
{
for(i=1; i<=n/2; i++)
{
ll t=a[i];
a[i]=a[n-i+1];
a[n-i+1]=t;
}
ans[1]=a[1];
len=1;
for(i=2; i<=n; i++)
{
if(a[i]>=ans[len])
ans[++len]=a[i];
else
{
ll pos=upper_bound(ans+1,ans+len+1,a[i])-ans;
ans[pos]=a[i];
}
}
if(len>=n-1)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
}
return 0;
}