Dancing Stars on Me

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

Input

The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi , yi , describe the coordinates of n stars. • 1 ≤ T ≤ 300 • 3 ≤ n ≤ 100 • −10000 ≤ xi , yi ≤ 10000 • All coordinates are distinct.

Output

For each test case, For each test case, please output ‘YES’ if the stars can form a regular polygon. Otherwise, output ‘NO’ (both without quotes).

Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0
Sample Output
NO
YES
NO

题意:给你n个整点的坐标,问是否能组成正n边形。

思路:只有n是4的时候才有可能满足题意。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <cstdio>
#include <string>
#include <stack>
#include <deque>
using namespace std;
const int MAX=1e5+7;
typedef long long ll;
struct A
{
    ll x;
    ll y;
}a[1010];
bool cmp(struct A p,struct A q)
{
    if(p.x==p.x)
        return p.y<q.y;
    return p.x<q.x;
}
int main()
{
    ll T,i,j,k,n,m;
    cin>>T;
    while(T--)
    {
        cin>>n;
        for(i=0;i<n;i++)
        {
            cin>>a[i].x>>a[i].y;
        }
        if(n!=4)
            cout<<"NO"<<endl;
        else
        {
            sort(a,a+n,cmp);
            ll ans1=abs(a[2].x-a[0].x);
            ll ans2=abs(a[3].x-a[1].x);
            ll ans3=abs(a[1].y-a[0].y);
            ll ans4=abs(a[3].y-a[2].y);
            if(ans1==ans2&&ans2==ans3&&ans3==ans4)
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值