G - Dancing Stars on Me

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.
1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000 All coordinates are distinct.
Output
For each test case, please output “YES” if the stars can form a regular polygon. Otherwise, output “NO” (both without quotes).
Sample Input

3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0

Sample Output
NO
YES
NO
题意:给出n个顶点,求这n个顶点连接起来的图形是否是正多边形。
思路:求出该多边形的重心,然后求各个顶点到重心的距离,如果都相等的话就是,否者就不是

#include<stdio.h>
#include<iostream>
#include<map>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
using namespace std;
typedef long long ll;
#define MAXN 105
#define INF 0x3f3f3f3f//将近int类型最大数的一半,而且乘2不会爆int

struct student {
	double x, y;
	double cc;
}stu[MAXN];

int main()
{
	int t;
	cin >> t;
	while (t--) {
		int n;
		double ans=0, tem=0, sum=0.0;
		scanf("%d", &n);
		for (int i = 0; i < n; ++i) {
			scanf("%lf %lf", &stu[i].x, &stu[i].y);
			ans += stu[i].x;
			tem += stu[i].y;
		}
		ans = ans * 1.0 / n;
		tem = tem * 1.0 / n;
		for (int i = 0; i < n; ++i) {
			stu[i].cc = sqrt(abs(ans - stu[i].x)*abs(ans - stu[i].x) + abs(tem - stu[i].y)*abs(tem - stu[i].y));
			sum += stu[i].cc;
		}
		if (sum == stu[0].cc*n*1.0)
			puts("YES");
		else
			puts("NO");
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值