Game on a Graph(第十届山东省ACM程序设计竞赛D题)

zoj4116

 

Game on a Graph

Sample Input
3
5
11212
4 6
0 1
0 2
0 3
1 2
1 3
2 3
5
11121
5 7
0 2
1 3
2 4
0 3
1 2
3 2
4 1
3
121
4 3
0 1
0 2
1 3
Sample Output
2
1
2

题意:给出一个k,代表下面输入字符串的长度,输入n,m代表n个点,然后有m对关系,是双向边,字符串为出场顺序,允许随便擦除一条边,规定使图为非连通图的人为输,问谁赢。

思路:使得边连通最少有n-1条边,所以m-n一定输,m-n+1一定赢。有一种情况是出场的人少于m,要从头来出场。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cstdio>
#include <cmath>
#include <map>
#include <set>
#include <queue>
using namespace std;
typedef long long ll;
const int M=1e5+10;
const int mod=1e9+10;
int a[M],b[100];
char s[M];
int main()
{
    int T,n,k;
    scanf("%d",&T);
    while(T--){
        memset(s,0,sizeof(s));
        int k;
        scanf("%d",&k);
        scanf("%s",s);
        int n,m,a,b;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
            scanf("%d%d",&a,&b);
        int kk=m-(n-1);
        kk%=k;
        if(s[kk]=='1')
            printf("2\n");
        else
            printf("1\n");
    }
    return 0;
}

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值